Error running surface labeling…missing file.

Viewing 3 reply threads
  • Author
    • #1963

      I am putting this under “Installation” since I am just now installing on a new computer, and reprocessing files which I have done previously on another computer…I must have done something wrong in getting set up correctly.
      Working on Windows 10; tried with ver 19a and also 18a. I have confirmed that I installed “MCR 2015b for 64-bit Win”, and also I installed the “Microsoft Visual C++ 2013 Redistributable Package”.

      Problem comes during surface labeling. Same problem whether I am using the UI tools, or using svreg commandline. Problem comes just after the ‘register_cc_curve program’, as shown in this log output:

      Registering corpus callosum curve
      The register_cc_curve program as a part of the RCC package is provided under the terms
      …… (a few log lines deleted for clarity)
      Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
      Error using load
      Unable to read file ‘C:\Users\todfl\Documents\Decker\MRI Processing\MRI Data\WPAFB HyperO2\CW007\Brainsuite\106_b_mprage_2.svreg.tmp\106_b_mprage_2.right.mid.cortex_smooth10.dfs_out_register_cc.mat’. No such file or directory.

      Indeed, in the svreg.tmp folder there is no ‘*.mid.cortex_smooth10.dfs_out_register_cc.mat’ file; but there are two ‘*.mid.cortex_smooth10.dfs_in_register_cc.mat’ files (left and right).

      Any suggestion as to what could cause this problem?

    • #1987


    • #2138

      I have resolved this problem. I installed Brainsuite ver 19b, as well as the required MATLAB Runtime R2019b. Now svreg is working fine again.

      I don’t have a clear idea of why it is now working, but I’m wondering if it could have something to do with having multiple MatLab Runtime versions installed, in addition to the full Matlab development environment (of yet a different version). I’m not aware of how the svreg code selects which Matlab environment to execute within — if it has to do with the order in which the different versions appear in the system PATH list, that could explain it. However, I tried messing with the order in the PATH variable and I couldn’t really reproduce the problem with ver 19b. So… who knows. I’m just happy it’s working again!

    • #2378
      Anand Joshi

      The installation needs the exact version of MCR (2019b) in this case.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.