Access Denied after CMC command for BDP

Viewing 3 reply threads
  • Author
    • #3222

      I have a problem occuring regarding the BDP command step. Each time I want to execute the command, a window pops up telling me that the app cannot be executed on this PC and that I have to contact the software provider. I’m running windows 10 and Brainsuite21a. My collegue assured me that it works on win10.

      Any help would be appreciated,

      Kind Regards

    • #3228
      David Shattuck

      Can you provide more details on how you are running it?

      Have you installed the Matlab Runtime 2019b?

      We developed and tested the latest release extensively on Windows 10, so it should run provided you have the Matlab Runtime installed. It has to be 2019b specifically. Mathworks link here:

      David Shattuck

      • #3243

        Thank you for the quick reply!

        I was running Matlab 2021b and will try it now with 2019b.
        I’m processing my data as follows:
        dicom to nifti using micro GL
        open brainsuite and drag in DTI.nii.gz, then process
        unpack DTI.nii.gz
        open CMC and use the following command:”D:\Utility\BrainSuite21a\bdp\bdp.exe” ”C:\Users\nicad\Desktop\PHD\DTI\Ersatzdaten\DCM2\T1.bfc.nii.gz” –tensor –FRT –FRACT –nii “C:\Users\nicad\Desktop\PHD\DTI\Ersatzdaten\DCM2\DWI.nii” -g “C:\Users\nicad\Desktop\PHD\DTI\Ersatzdaten\DCM2\DWI.bvec“ -b “C:\Users\nicad\Desktop\PHD\DTI\Ersatzdaten\DCM2\DWI.bval“ –generate-stats

        Kind regards,

        Adrien Nicolay

        • This reply was modified 2 years, 4 months ago by Whiiz.
      • #3246

        hi Adrien,
        By looking at your command line I can detect some errors.
        This would be an example that should runs fine:
        bdp.exe 2523412.bfc.nii.gz –tensor –FRT –FRACT –nii 2523412.dwi.nii.gz -g 2523412.dwi.bvec -b 2523412.dwi.bval –generate-stats

        Notice how some flags have only one ‘-‘ (like -g and -b). But, others have ‘–‘ (like –tensor, –FRT, –FRACT, –nii, –generate-stats)

        Also, for –nii flag use the extension ‘file.nii.gz’. No need to unzip the files.

        Please adapt these changes in your code and let us know.
        All the best,
        Clio Gonzalez

      • #3247

        now I am realizing that when trying to write 2 dashes here only one appears one. You can follow what I tried to say if you look in here:

        Notice how some flags have only one dash ‘-‘ (like -g and -b). But, others have 2 dashes ‘– -‘(like tensor, FRT, FRACT, nii, generate-stats)

      • #3252

        I’ve tried to run the tutorial with the material but to no aveil. I still get the error message access denied and that the app cannot be executed. I’ve also tried repairing in admin mode with sfc/ scannow.
        Prompt for reference:
        Microsoft Windows [Version 10.0.19042.1466]
        (c) Microsoft Corporation. Alle Rechte vorbehalten.

        C:\Users\nicad>”D:\Utility\BrainSuite21a\bdp\bdp.exe” C:\Users\nicad\Downloads\BrainSuiteTutorialDWI\2523412.bfc.nii.gz –tensor –FRT –nii C:\Users\nicad\Downloads\BrainSuiteTutorialDWI\2523412.dwi.nii.gz -g C:\Users\nicad\Downloads\BrainSuiteTutorialDWI\2523412.dwi.bvec -b C:\Users\nicad\Downloads\BrainSuiteTutorialDWI\2523412.dwi.bval
        Zugriff verweigert
        (tensor, FRT and nii all with doubledashes of course)

      • #3245

        After installing the 2019b runtime i get the same error.

      • #3248
        David Shattuck

        If you want to show exact commands, I think you can use html code blocks. Unfortunately, WordPress converts double dashes into a single em dash character (em dashes are the width of an m character, en dashes are the width of an n character).

        For example, if you type


        Wordpress will display


        You can also use back ticks in place of the code tags.

        If you want to show a command line, please put try the code tags.

    • #3242

      Post deleted

    • #3253


      It worked after I reinstalled brainsuite21a on the same drive ass the file location.

      Thanks for all your help! :)

      Kind regards,


Viewing 3 reply threads
  • You must be logged in to reply to this topic.