Registration process error

Forums Forums Surface and Volume Registration (SVReg) Registration process error

This topic contains 17 replies, has 6 voices, and was last updated by  Forough 3 days, 18 hours ago.

  • Author
    Posts
  • #273

    wy
    Participant

    Hello,

    I am still in the processing step, and I’m getting these errors. Please let me know if you can help!
    Error occurred during label left hemisphere surface
    Error occurred during label right hemisphere surface

    dyld: Library not loaded: @ loader_path/libmwmclmcrrt.7.17.dylib
    Referenced from: Application/BrainSuite15c/svreg/bin/svreg_label_surf_hemi.app/Contents/MacOS/svreg_label_surf_hemi
    Reason: image not found
    /Application/BrainSuite15c/svreg/bin/svreg_label_surf_hemi.sh: line 100: 5526 Trace/BPT trap:5 ${exe_dir}/svreg_label_surf_hemi.app/Contents/MacOS/svreg_label_surf_hemi “${FILEPREFIX}” “${ATLASPREFIX}” “${HEMI}” “${FLAGS}”

    Can someone help please?

  • #274

    Anand Joshi
    Participant

    Can you please make sure that you have installed Matlab MCR?
    Please make sure that you have followed the installation instructions here:
    http://brainsuite.org/quickstart/installation/

  • #580

    leonidastra86
    Participant

    Same problem here and i have already installed Matlab with the compiler included.
    Could you please give us a picture how the text should look like?
    I am running MacOs Sierra.

    Thank you!

  • #581

    Anand Joshi
    Moderator

    Thank you for running BrainSuite. Here are some instructions for MacOS Sierra. Please make sure that you have followed them. Also make sure that you are running the latest version of BrainSuite.
    http://brainsuite.org/2016/11/brainsuite-on-macos-sierra-10-12/

    Thanks,

  • #583

    leonidastra86
    Participant

    Thank you very much for your answer. I have followed already the instructions, otherwise I wouldn’t be able to reach the last step. I think, however, that I made a mistake in svreg_label_surf_hemi.sh code. I have Matlab 2016a.

  • #584

    Anand Joshi
    Moderator

    Please make sure that you have installed matlab MCR 2015b installed.
    The later or earlier versions of Matlab MCR do not work. The exact version 2015b is required. The link for the MCR in the installation instructions.
    http://brainsuite.org/quickstart/installation/

  • #585

    leonidastra86
    Participant

    OK, I will try it out and let you know. Thank you so much!

  • #600

    yaqiong
    Participant

    Hi leonidastra,

    Did the suggestions help you trouble-shoot the problem? Are you able to run svreg to the end?
    I have the similar issue here too.

    Thanks a lot!
    Yaqiong

  • #601

    leonidastra86
    Participant

    Yes, the problem was fixed but I have to open the program every time through Terminal/Console by uninstalling the temporary files.

  • #621

    yaqiong
    Participant

    Did you run /Applications/BrainSuite16a1/BrainSuite16a1.app/Contents/MacOS/BrainSuite16a1 –uninstall

    Because when I try to run it the GUI poped up and I did not have a chance to type in “yes” in the terminal to prompt.

  • #622

    leonidastra86
    Participant

    Exactly, from my Macbook I always run the program through Terminal with
    /Applications/BrainSuite16a1/BrainSuite16a1.app/Contents/MacOS/BrainSuite16a1 –uninstall
    When I run it from windows, then it is not necessary.

  • #1243

    wy
    Participant

    I still have the same error despite doing the above recommendation.
    I am using brain suite 18a

  • #1244

    leonidastra86
    Participant

    The 18a should work on Mac without using the above recommendation, just run it.

  • #1245

    wy
    Participant

    I did run it! That’s how i got the error!

  • #1246

    leonidastra86
    Participant

    Do you have preinstalled any older version of brain suite? Try to radically remove everything and then re install it.

  • #1867

    Forough
    Participant

    Hi guys
    Would you please help me on this error? this occurs in hemisphere labeling step.I changed parameters bu still have this error.
    Thanks in advance
    ‘Labeling left hemisphere
    Error using copyfile
    The system cannot find the path specified.

    Error in svreg_label_surf_hemi (line 116)

    MATLAB:COPYFILE:OSError’

  • #1885

    Anand Joshi
    Moderator

    Have you run the full brainsuite sequence or are directly starting with the labeling step. You should run the entire brainsuite sequence. First please run through the tutorial data available from our website to make sure that the software is installed correctly.

  • #1889

    Forough
    Participant

    Hi Anand
    Thanks for your feedback…yes i run the full brainsuite sequence…i run it on my own data in 11 subjects and it works great…but in 5 subject i have this problem…i will installed it again
    thanks
    Forough

You must be logged in to reply to this topic.