parpool error

This topic contains 2 replies, has 2 voices, and was last updated by  todflak 5 months, 1 week ago.

  • Author
    Posts
  • #1203

    todflak
    Participant

    I have been using BS ver 16 and 17 for over a year, running using command line, on Windows platform.
    I just upgraded to BS version 18a.
    Now when I try to run svreg, I get the error below:

    > In svreg (line 28)
    The whole surface volume registration and labeling sequence takes about 90-100 min.
    Starting parallel pool (parpool) using the ‘local’ profile … Error using parpool (line 103)
    You requested a minimum of 3 workers, but the cluster “local” has the NumWorkers property set to allow a maximum of 2 workers. To run a communicating job on more workers than this (up to a maximum of 512 for the Local cluster), increase the value of the NumWorkers property for the cluster. The default value of NumWorkers for a Local cluster is the number of cores on the local machine.

    Error in svreg (line 169)

    parallel:cluster:LocalProfileNumWorkersExceeded

    So, I understand this has something to do with a setting for number of parallel processes. But I have no idea where to set the NumWorkers property. Is this documented?
    Furthermore, I found that by adding the command line option “-U” (to specify single-threaded mode), everything seems to work again… and, surprisingly, it looks like the svreg process is utilizing all four cores on my Windows machine! What gives?

    Thanks,
    Tod

  • #1204

    Anand Joshi
    Moderator

    You can delete .matlab or .mcr directory that contains settings of matlab. so deleting these directories will clear those settings.
    You could also use -U flag which will process one cortical hemisphere at a time, and use multiple cores whenever possible.

  • #1205

    todflak
    Participant

    Of course, I should have realized that this was a MatLab issue. Thanks for the clarification!
    -Tod

You must be logged in to reply to this topic.