svreg warp

This topic contains 3 replies, has 2 voices, and was last updated by  Anand Joshi 3 months, 1 week ago.

  • Author
    Posts
  • #1564

    LDO
    Participant

    I have a modified atlas made out of the default BrainSuiteAtlas1 using the Label editor gui. The label description is modified accordingly. Modifications just amount to making subparcels from large gyri, and merging smaller ones, to create parcels of overall similar sizes.

    I would like to use the default svreg results to warp the modified atlas onto a subject brain. My notion is that the same warp transformation resulting from the original BrainSuiteAtlas1 running svreg should be applicable to the modified Atlas derived from it.

    I would prefer not to create a completely new Atlas and install it in BrainSuite for many reasons, especially since I have been tweaking the modifications very frequently. Many troubles when I tried to do that and it takes too long to rerun the whole process every time I modify the Atlas. It should be simple enough to run the default svreg sequence with a subject brain, then apply the default Atlas’ transformation using the modified Atlas, no?

    I won’t go through all of the things I have tried unsuccessfully. I hope you have a simple way to do this.

    I am using the command line tools, Windows10, BrainSutie18a, Matlab. This is part of a processing pipeline that has been really really helpful.

    I hope the question is clear and you are able to help. Thank you very very much.

    Larry Olson

    PS- your email support link ‘support@brainsuite.org’ is undeliverable

  • #1565

    LDO
    Participant

    Joshi,

    ———————————————————————————————
    FYI, I sent email to your response but got this:
    ” —– The following addresses had permanent fatal errors —– <cbhushan@usc.edu>
    (reason: 550-5.2.1 The email account that you tried to reach is disabled. Learn more at)”
    ———————————————————————————————

    Thank you for your prompt response! Difficult to troubleshoot, but I get this error:

    C:\Program Files\BrainSuite18a\svreg\bin>svreg_labelwith_atlas.exe C:\Users\lolson\Desktop\JJnew\IA\bfc\nrT1 C:\Users\lolson\Desktop\BrainSuiteAtlas1\mri mod
    Error using copyfile
    No matching files were found.

    Error in svreg_labelwith_atlas (line 77)

    MATLAB:COPYFILE:FileDoesNotExist

    Not sure which files are missing?
    Thanks

  • #1568

    LDO
    Participant

    Yes, this file exists: C:\Users\lolson\Desktop\JJnew\IA\bfc\nrT.svreg.init.label.nii.gz as C:\Users\lolson\Desktop\JJnew\IA\bfc\nrT1.svreg.init.label.nii but has been converted to uncompressed nifty for compatibility with Matlab SPM tools.

    Is that really a problem?

  • #1805

    Anand Joshi
    Moderator

    Discussed this by email with you but posting here so that it is useful to others.
    Yes, the program expects .gz extension. So if you compress it back the program should work.

You must be logged in to reply to this topic.