Cannot launch BrainSuite

Forums Forums Installation and Setup Cannot launch BrainSuite

Viewing 4 reply threads
  • Author
    Posts
    • #3082
      d_kom
      Participant

      Hi everyone,
      I downloaded BrainSuite 21a (I’m using Linux) and followed the installation steps. I installed the 2015b Matlab Runtime. I substituted “16a” with “21a” in the commands that are listed in the instructions, because I am assuming this is an error and that instructions have not been updated (otherwise, not sure why I would need two versions of BrainSuite at the same time).
      When I try to launch BrainSuite using /opt/BrainSuite21a/bin/BrainSuite21a command in the Terminal, I get the following message:

      qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
      This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

      Available platform plugins are: xcb.

      Aborted (core dumped)

      Should I really reinstall the whole thing from scratch (if yes, should I first uninstall and then download everything again or just repeat the installation command) or is there a better solution?
      Thanks in advance!

    • #3083
      David Shattuck
      Keymaster

      hi –

      Which version of Linux are you using?

      Can you try installing xinerama? On some platforms, this will fix the issue. Specifically, this fixed that issue on Ubuntu 16.04.

      sudo apt-get install -y libxcb-xinerama0

      For BrainSuite21a, the version of Matlab Runtime to use is 19b. Direct link: https://ssd.mathworks.com/supportfiles/downloads/R2019b/Release/3/deployment_files/installer/complete/glnxa64/MATLAB_Runtime_R2019b_Update_3_glnxa64.zip

      That isn’t causing the launch problem, but it is necessary to run some of the programs in BrainSuite.

      Let us know if that fixes the problem — if not we can get some further information and help you resolve this.

      thanks,
      David Shattuck

    • #3086
      d_kom
      Participant

      Hi David,
      yes, installing xinerama fixed it, thank you!

      (I am indeed using Ubuntu 16.04)

      I will now install Runtime 19b. I don’t know if you are one of the site admins, but if yes, maybe you could change the information on the Download page, because it still says 2015b, in the installation instructions for BrainSuite21a, and also Brainsuite16 is mentioned.

      Thanks a lot, once again!
      Darko

    • #3088
      d_kom
      Participant

      Hi David,
      I have a different problem now. After installing MATLAB Runtime 2019b, I was directed to this guide:
      https://de.mathworks.com/help/compiler/mcr-path-settings-for-run-time-deployment.html

      My shell is Bash, but doing step 1 doesn’t result in anything being echoed in the terminal, and doing step 2 makes the terminal seemingly work forever, until I have to terminate the process with Ctrl+C.

      Can I just edit my .bashrc file by adding th following line to it:
      export LD_LIBRARY_PATH=$(the path copied from the matlab installation window)

      Thanks a lot for your help!

    • #3094
      David Shattuck
      Keymaster

      hi –

      For use with BrainSuite, you can usually skip adding the environment variables to your path. We have done this in the shell scripts that we use to call the compiled MATLAB programs. If you look, for example, at the bdp.sh script, you can see this bit:

      # Set up path for MCR applications.
      LD_LIBRARY_PATH=.:${BrainSuiteMCR}/runtime/glnxa64 ;
      LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${BrainSuiteMCR}/bin/glnxa64 ;
      LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${BrainSuiteMCR}/sys/os/glnxa64;
      MCRJRE=${BrainSuiteMCR}/sys/java/jre/glnxa64/jre/lib/amd64 ;
      LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${MCRJRE}/native_threads ; 
      LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${MCRJRE}/server ;
      LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${MCRJRE}/client ;
      LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${MCRJRE} ;  
      XAPPLRESDIR=${BrainSuiteMCR}/X11/app-defaults ;
      export LD_LIBRARY_PATH;
      export XAPPLRESDIR;
      
      BDPEXEDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd)" ;
      export BDPEXEDIR;
      
      "${exe_dir}/bdp" "$@"

      which sets the library paths before calling bdp. BrainSuiteMCR gets set at the start of the script based on standard installation locations, or you can set it as an environment variable (useful for you install it in a non-default location). This strategy should reduce the impact of the installation.

      You can undo the changes you made to your .bashrc file and give it a try.

      thanks,
      David

Viewing 4 reply threads
  • You must be logged in to reply to this topic.